Gun and Game Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
53 Posts
Discussion Starter · #3 ·
Mags are in great condition. I dont know what to look for if there is a problem with the ejector or the feed ramp (or even the mags). I thought these might be more likely the culprit. I thought it might be the ammo at first because I was using reloads. But I changed back to factory ammo and it still doesn't feed right.
 

· Сергей Иванович Мосин.
Joined
·
2,555 Posts
Have never had anything but issues with Paras, that's why I tend to stick to Springfields.
 

· Premium Member
Joined
·
4,133 Posts
Mags are in great condition. I dont know what to look for if there is a problem with the ejector or the feed ramp (or even the mags). I thought these might be more likely the culprit. I thought it might be the ammo at first because I was using reloads. But I changed back to factory ammo and it still doesn't feed right.

Try going to the Para Owner of America site/forum. I'm not familiar with the P10/45 but feel sure it's a minor issue. I have had a couple 14/45's over the past 9 years and have never had any problems other than bent magazine feed lips. The only changes I've made were springs and buffers along with normal maintenance. Love both and can't wait for my next.
 

· Registered
Joined
·
14 Posts
Sending my Warthog back to Tenn. to the shop. Am having feeding probs also. Sending three mags with it. Carried it for about three/four yrs but fired it very little. Maybe it just needs a little more playing with. Started FTF with hollow points. Went to ball and it did fine for a short while.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top