Gun and Game Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Maybe yall could help me. I take my m1 garand out for a spin at the local 100 yard range. I use 150 grain commercial ball ammo. They only let me load 1 round in at a time so no en-block clip. Whenever I shoot, my trigger housing on it seems everyother shot will come out the bottom, the trigger guard is still locked into place but the whole assembly just pops out. First question is:

Is it bad to shoot just single rounds without the enblock

Second:

Why would my trigger housing pop out when I shoot.

My serial number is 794xxx and its a springfield. Any Thoughts?
 

·
Premium Member
Joined
·
1,087 Posts
OUchyyyyy:bigeyes: . The single shots are fine but the group falling out is not. Maybe the stock is to big?? Or the lugs on the trigger guard are worn off? Maybe the receiver slots are damage? Take it out of the stock and put it together looking at the locking points for the trigger guard lugs as it goes into the receiver. That is key.

You will have to look with the stock on the rifle as trying to line it up when stock is off can be a mess as the stock guides you into the slots correct spot. When no stock is on it you tend to put it where it doesn't belong. Let us know. Rick B
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
The stock does seem really loose, it even has the original brass pins in the butt of it. I can hold the stock and shake it and it will wiggle just a tad with the receiver. Seems boyds is out of stock and i need just a stock to shoot it and hang on to the original. Thanks
 

·
Registered
Joined
·
725 Posts
One shot at a time. Sounds like you shoot at the same outdoor range I go to. You don't happen to be shooting in Westchester, NY, by any chance?
 

·
Registered
Joined
·
2,219 Posts
If the stock reciever is moving any at all its to much.Sounds like you have bad lock up. If your trigger gaurd still locked shut when it falls out? If so I suppose it is the trigger assem. lugs are worn. Pull out the assembly and post or send me a picture of the side of it.
You may be heading for worse problems buy using commercial ammo. The bullit weight isn't the factor, its the burn rate of the powder used in commercial ammo. Can I ask what brand, type you are using?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
ill take a picture of that. It is the green remington box, soft lead tips. I am going to a gun show on the 15th should i pick up alot of surplus ammo?
 

·
Registered
Joined
·
2,219 Posts
Yep, you are asking for trouble. Surplus M2 ball ammo only, the gas system isn't set up for commercial ammo pressures. Try and buy non corrosive ammo, its alot less work cleaning.
 

·
Registered
Joined
·
9,224 Posts
no the pressure is not knocking out the trigger group, but it is not healthy for the op rod. 2 things, your stock is probably compressed through the reciever and trigger guard area, 2 your lugs on the trigger group are most likely badly worn. the lugs are why your trigger group pops out, the loose stock just makes for a poor shooting rifle.
 

·
Premium Member
Joined
·
1,087 Posts
Like I said the lugs on the guard are probably the culprit but also a welded up receiver that was Destroyed and brought back to life can be the problem. Note: there are no Rewelds as the receiver was not welded originally, it is a welded receiver when this is done.

Do you notice any heavily machining marks or bubbles in the center of the receiver around the center of the bolt area? I have seen when they grind the welds done they have removed the lug slots or shortened them over grinding. Rick B
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #12 ·
heres the photo links

<a href="http://allyoucanupload.webshots.com/v/2005948373324407185"><img border="0" src="http://aycu22.webshots.com/image/6581/2005948373324407185_th.jpg" alt="Free Image Hosting at allyoucanupload.com"/></a>


<a href="http://allyoucanupload.webshots.com/v/2005904433485685007"><img border="0" src="http://aycu13.webshots.com/image/7452/2005904433485685007_th.jpg" alt="Free Image Hosting at allyoucanupload.com"/></a>


<a href="http://allyoucanupload.webshots.com/v/2005995106270588939"><img border="0" src="http://aycu23.webshots.com/image/8662/2005995106270588939_th.jpg" alt="Free Image Hosting at allyoucanupload.com"/></a>

<a href="http://allyoucanupload.webshots.com/v/2005929720682025324"><img border="0" src="http://aycu33.webshots.com/image/7792/2005929720682025324_th.jpg" alt="Free Image Hosting at allyoucanupload.com"/></a>
 

·
Premium Member
Joined
·
1,087 Posts
Lety me try. You need to put a
. Let see if that shows up. Rick B



I tried to upload what you have on one link but you apparently have to many charachters in the link or a passworded link.
 
1 - 15 of 15 Posts
Top